Pisaliśmy kilka dni temu o nowych sterownikach ATI obsługującę również karty „Powered by…”. Jak wygląda sytuacja z ich funkcjonalnością ?

Paczuszka ze sterownikami jest w formacie rpm. Producent co prawda, podaje informację czym przekształcić ją w deby, ale po wykonaniu tej operacji pojawia się konflikt bibliotek, więc trzeba troszkę pogrzebać. Zależało mi na czasie, więc po prostu przekopiowałem pliki w odpowiednie miejsca. Nasŧępnia należy zainstalować moduł fglrx. Jest to banalne tylko dla użytkowników pewnych rpmowych dystrybucji wyjętych „prosto z podełka”. Najnowsze jądro jakie jest supportowane to 2.4.18 i oczywiście nie w zwykłej postaci, tylko spatchowanej przez developerów wyżej wymienionych dystrybucji. Po długich bojach z przystosowaniem go do mojego 2.4.19 rezygnuję (bo są co prawda źródła modułu, ale po skompilowaniu nie chciały działać na czymś nowszym niż 2.4.18). Szybkie rozpakowanie kernela 2.4.18, kompilacja jądra, reboot, kompilacja modułu, startx i… błędy DRI. Błąd zostaje szybko znaleziony i naprawiony – kernel był skompilowany gcc-3.2 a moduł 2.95. Kolejny test – teoretycznie wszystko działa w porządku. Testy praktyczne (po przejściu z driverów DRI):

  • Quake 3 przyrost z 75 do 130 klatek na sekundę (timedemo1; demo demo001),
  • RCTW pojawiły się dodatkowe tekstury (niebo w intrze etc),
  • Flightgear pojawienie się menu u góry ;);
  • UT2003 wreszczie chodzi, ale w nawet w 640 x 480 nie da sie grać. Tragicznie wolno.

Dołączona jest jeszcze ulepszona wersja glxgears oraz graficzny programik do konfiguracji xfree. Podsumowując, dobrze, że ukazały się sterowniki. Źle, że w takiej postaci co zdecydowanie jest problematyczne. Czekam na wersję do nowego kernela.

Na zakończenie do testów kart graficznych polecam kolekcje demek linuksowych.

Archiwalny news dodany przez użytkownika: bluszcz.
Kliknij tutaj by zobaczyć archiwalne komentarze.

Share →