Zapraszam do lektury opóźnionych co prawda, ale nadal aktualności ze świata Debiana!

Witaj w dwudziestym ósmym w tym roku numerze DWN, tygodnika dla osób zainteresowanych i związanych z Debianem. Bruce Perens ostrzegł przed właścicielami patentów, którzy zgłaszają pozwy przeciwko deweloperom Wolnego Oprogramowania. Ostatni taki pozew został zgłoszony przeciwko Red Hatowi. Steinar Gunderson zauważył, że sieć buildd jest naprawdę zaskakująco szybka ostatnio. Jego pakiet został zbudowany na ośmiu architekturach w godzinę.

Lista dyskusyjna debian-devel. Cesare Leonardi zastanawiał się kto może brać udział w dyskusjach na liście dyskusyjnej debian-devel, bo uwaga skupiana na niektórych wiadomościach pozwala odnieść wrażenie, że ludzie, którzy nie biorą czynnego udziału w projekcie są członkami drugiej klasy. Matthew Garrett dodał, że to po prostu znaczy, że jeżeli ktoś nie bierze udziału w rozwoju Debiana, nie powinien żądać czegokolwiek od projektu.

Ukryte pliki w pakietach Debiana. Klaus Ethgen zauważył, że wiele pakietów zawiera pliki ukryte w /usr. Linas Åvirblis dodał, że tego typu pliki mogą wprowadzać w błąd skanery bezpieczeństwa, a Henrique de Moraes Holschuh stwierdził, że poza katalogami domowymi użytkowników nie powinno być w systemie plików ukrytych. Mike Hommey ujawnił, że wspomniane pliki są pomocne przy rejestracji komponentów podczas aktualizacji, a Joey Hess wyjaśnił, że mooix używa ukrytych plików do umieszczania flag dla obiektów.

Kernel Debiana z grafiką podczas rozruchu. Paul van der Vlis zapytał jak skonfigurować wyświetlanie grafiki podczas rozruchu systemu bez potrzeby samodzielnej kompilacji kernela. Paul Wise zaraportował, że pakiet splashy z experimental działa wyłącznie w srodowisku użytkownika i nie wymaga łatkernela do działania.

Rozwiązania dotyczące zależności. Andreas Barth zaraportował o spotkaniu z badaczami z Rencontres Mondiales du Logiciel Libre (RMLL) podczas którego zostało wymienionych wiele pomysłów związanych z systemem zależności w Debianie. Sieć zależności pakietów Debiana została skonwertowana do logicznego problemu spełniania zależności (SAT), by zwykły program rozwiązujący taki problem mógł znaleźć rozwiązanie. To podejście wytworzyło ciekawe wyniki takie jak aura Debiana, która reprezentuje status „instalowalności” danych pakietów albo temperatura SAT oznaczająca trudność rozwiązywania zestawu zależności.

Następna Konferecja Debiana w Edynburgu. Neil McGovern ogłosił po długim spotkaniu, że następna konferencja Debiana będzie miała miejsce w Edynburgu, w Wielkiej Brytanii. Innym kandydatem gdzie miałaby odbyć się konferencja było Sarajewo w Bośni. Oba miejsca były wcześniejwizytowane oraz przeprowadzono wiele dyskusji z lokalnymi społecznościami obu miast.

Poprawki bezpieczeństwa. Zasada jest prosta. Upewnijcie się, że zaktualizowaliście swoje systemy, jeśli korzystacie z poniższych pakietów.

  • DSA 1105: xine-lib — Odmowa usługi.
  • DSA 1106: ppp — Podwyższanie uprawnień.
  • DSA 1107: gnupg — Odmowa usługi.
  • DSA 1108: mutt — Wykonywanie dowolnego kodu.

Pakiety nowe lub warte uwagi. Następujące pakiety zostały ostatnio dodane do niestabilnego archiwum Debiana lub zawierają ważne poprawki.

  • adept-installer — Simple user interface for application management.
  • bonfire — CD/DVD burning application.
  • buildbot — System to automate the compile/test cycle.
  • cl-launch — Uniform frontend to running Common Lisp code from the shell.
  • cl-soap — Open Source implementation of SOAP for Common Lisp.
  • codeine — Simple KDE video player.
  • collectd — Statistics collection daemon.
  • curlftpfs — Filesystem to access FTP hosts based on FUSE and cURL.
  • dchroot-dsa — Execute commands in a chroot environment.
  • facter — Library for retrieving facts from operating systems.
  • freetennis — Free Tennis – simulation game.
  • gadmintools — GTK+ server administration tools.
  • geany — Fast and lightweight IDE.
  • gnome-hearts — The classic hearts card game for the GNOME desktop.
  • gplanarity — Simple puzzle game involving untangling planar graphs.
  • haxml — Utilities for using XML documents with Haskell.
  • hpodder — Tool to scan and download podcasts (podcatcher).
  • icon-naming-utils — Script for maintaining backwards compatibility of Tango Project.
  • kbfx — Alternative to K-Menu for KDE.
  • khmerconverter — Converts between legacy Khmer encodings and Unicode.
  • kolabadmin — Administration tool for kolab groupware server.
  • kwlan — Wpasupplicant frontend for KDE.
  • lastmp — MPD client for lastfmsubmitd.
  • mailtextbody — Tool to return the body of an email message.
  • menhir — Parser generator for OCaml.
  • mg — Microscopic GNU Emacs-style editor.
  • mini-httpd — Small HTTP server.
  • openmpi-bin — High performance message passing library.
  • pengupop — Online multiplayer clone of Bust a Move.
  • picprog — Microchip PIC serial programmer software.
  • planet — Flexible feed aggregator.
  • pubtal — Template driven web site builder for small sites.
  • puppet — Centralised configuration management for networks.
  • sbaz — Scala Bazaars package-distribution system.
  • scala — Scala programming language.
  • tcpser — Emulate a Hayes compatible modem.
  • twolame — MPEG Audio Layer 2 encoder (command line frontend).
  • uswsusp — Tools to use userspace software suspend provided by Linux.
  • vdrift — Open Source drift racing simulation.
  • vzctl — Server virtualisation solution.
  • wbrazilian — Brazilian Portuguese wordlist.
  • wikipediafs — View and edit Wikipedia articles as if they were real files.
  • wmii2 — Lightweight tabbed and tiled X11 window manager, version 2.
  • wportuguese — European Portuguese wordlist.
  • xapian-tools — Basic tools for Xapian search engine library.

Pakiety osierocone. W tym tygodniu osierocono 7 pakietów. Poszukiwani są dla nich nowi opiekunowie. W sumie jest już 321 opuszczonych pakietów. Podziękowania dla ich poprzednich opiekunów, którzy poświęcili swój czas dla społeczności Wolnego Oprogramowania. Zajrzyj na strony WNPP po pełną listę, a jeśli chcesz przejąć jeden z tych pakietów, dodaj informację do raportu o błędzie i zmień jego tytuł na ITA:. Aby dowiedzieć się, które pakiety zainstalowane w Twoim systemie mają status osieroconych skorzystaj z programu wnpp-alert z pakietu devscripts

Pakiety usunięte. W zeszłym tygodniu usunięto 86 pakietów z archiwum Debiana:

  • siptoolbox — Scilab image processing toolbox (SIP)
    Bug#307365: Request of QA: orphaned, unbuildable, has never been part of a stable release.
  • okle — DVD player for KDE
    Bug#333816: Request of QA, orphaned, superseded by kaffeine.
  • cvsbook — Open Source Development with CVS, the book
    Bug#337849: Request of maintainer, outdated and new version unpackagable, long time RFAed.
  • mozilla-firefox-locale-ar — Mozilla Firefox Arabic Language/Region Package
    Bug#348355: Request of maintainer, superseded by mozilla-firefox-locale-all.
  • skk — SKK Dictionary server
    Bug#353627: Request of QA, orphaned, RC bug, out of date.
  • drsync — Wrapper for file synchronisation via rsync
    Bug#354843: Request of maintainer, orphaned, RC bug, dead.
  • apcd — APC Smart UPS daemon
    Bug#358513: Request of maintainer: obsolete, use apcupsd.
  • mozilla-firefox-locale-tr — Mozilla Firefox Turkish Language/Region Package
    Bug#359202: Request of maintainer, superseded by mozilla-firefox-locale-all.
  • buildtool — Portable build infrastructure
    Bug#359259: Request of maintainer, dead, no longer supported, rarely used.
  • vdradmin — Web-based administration tool for vdr
    Bug#359951: Request of maintainer, superseded by vdradmin-am.
  • drbd — RAID 1 over TCP/IP for Linux utilities
    Bug#361263: Request of maintainer, obsolete; replaced by drbd0.7 and drbd8.
  • kernel-patch-uml — User-mode Linux (kernel patch)
    Bug#361607: Request of QA, obsolete.
  • eudc — Emacs Unified Directory Client
    Bug#361895: Request of maintainer, merged in to emacs21.
  • xen — Patch to Linux for the Xen sub-architecture
    Bug#362026: Request of QA: obsolete, superseded by xen-3.0.
  • worker-doc — Documentation for the Worker file manager
    Bug#362212: Request of maintainer, dead upstream.
  • zope-cmf1.4 — Zope content management framework (CMF), 1.4 branch
    Bug#362284: Request of maintainer, superseded by zipe-cmf1.
  • zope-i18nlayer — Fully transparent multilingual content solution for zope/plone
    Bug#362286: Request of maintainer, low usage; better alternatives is zope-linguaplone.
  • zope-i18nfolder — Zope product for handling multilingual folders
    Bug#362287: Request of maintainer, low usage; better alternatives is zope-linguaplone.
  • zope-portaltransport — Subscription service for cmf content types
    Bug#362290: Request of maintainer, low usage; no rev-deps.
  • zope-zattachmentattribute — Simple attachment handler for zope products
    Bug#362303: Request of maintainer, superseded by zope-attachmentfield.
  • zope-zaaplugins — Collection of ZAttachment plugins
    Bug#362304: Request of maintainer, superseded by zope-attachmentfield.
  • kernel-patch-powerpc-2.4.27 — Build infrastructure for kernel version 2.4.27-apus
    Bug#362319: Request of maintainer, obsolete.
  • liboil0.2 — Library of Optimized Inner Loops
    Bug#362506: Request of maintainer, superseded by liboil0.3.
  • resmgr — Resource manager library [development files]
    Bug#362822: Request of maintainer, security problems; largely obsoleted by udev.
  • koffice-i18n — Afrikaans (af) translations for KOffice
    Bug#362841: Request of maintainer, superseded by koffice-l10n.
  • dacode — Powerful and full-featured news engine written in PHP
    Bug#363063: Request of maintainer, unmaintained upstream; obsolete.
  • gnome2-user-docs — GNOME 2 User’s Guide
    Bug#363941: Request of maintainer, superseded by gnome-user-docs.
  • timecode — C++ hierarchy which controls and describes time code
    Bug#364055: Request of QA, broken.
  • ucd-snmp — NET SNMP (Simple Network Management Protocol) Library
    Bug#364094: Request of maintainer, superseded by net-snmp; dead upstream.
  • nvidia-modules-i386 — NVIDIA binary kernel module
    Bug#364218: Request of maintainer, superseded by nvidia-graphics-modules-i386.
  • cherrypy — Python-based tool for developing dynamic web sites
    Bug#364432: Request of maintainer, obsolete; superseded by python-cherrypy.
  • xsim — X Simple Input Method
    Bug#364618: Request of maintainer, dead upstream; alternatives exist.
  • kernel-patch-adamantix — Kernel patches introduced in Adamantix
    Bug#364684: Request of maintainer, RC-buggy; unmaintained.
  • rsbac-admin — Rule Set Based Access Control administrative utilities
    Bug#364685: Request of maintainer, RC-buggy; unmaintained.
  • mindi-partimagehack — Disk partition imaging utility for Mindi/Mondo
    Bug#364701: Request of maintainer,superseded by ntfsclone; dead upstream.
  • libmysqlclient-lgpl — LGPL-licensed client library for MySQL databases
    Bug#366590: Request of maintainer, obsolete.
  • libhonyaku-damashii-ruby — Honyakudamashii client library for Ruby
    Bug#367676: Request of maintainer, obsolete.
  • liboptparse-ruby — Command line option parser class for Ruby 1.6
    Bug#367896: Request of maintainer, ruby 1.6 removal.
  • drb — Distributed Ruby for Ruby 1.6
    Bug#367898: Request of maintainer, ruby 1.6 removal.
  • libcsv-ruby — CSV data format parse module for ruby1.6
    Bug#367899: Request of maintainer, ruby 1.6 removal.
  • aget — Multithreaded HTTP Download Accelerator
    Bug#367900: Request of maintainer, dead upstream.
  • xmlrpc4r — XML-RPC support for Ruby 1.6
    Bug#367902: Request of maintainer, ruby 1.6 removal.
  • webrick — Sim
    ple HTTP Server Toolkit for Ruby 1.6.x
    Bug#367904: Request of maintainer, ruby 1.6 removal.
  • erb — Tiny eRuby for Ruby 1.6
    Bug#367908: Request of maintainer, ruby 1.6 removal.
  • libopenssl-ruby — OpenSSL interface for Ruby
    Bug#367917: Request of maintainer, ruby 1.6 removal.
  • libmutexm-ruby — Yet another mutex library for Ruby 1.6
    Bug#367926: Request of maintainer, ruby 1.6 removal.
  • libnet-acl-ruby — Simple Access Control Class for Ruby 1.6
    Bug#367927: Request of maintainer, ruby 1.6 removal.
  • ruby-eserver — Generic multi-threaded e-service server in Ruby 1.6.x
    Bug#367928: Request of maintainer, ruby 1.6 removal.
  • alltraxclock2 — Analog clock plugin for GKrellM2
    Bug#368123: Request of QA, orphaned; duplicate of alltraxclock.
  • moniwiki — MoniWiki is yet another WikiEngine written in PHP
    Bug#368153: Request of QA, orphaned.
  • sdl-ttf1.2 — TrueType font library for Simple DirectMedia Layer
    Bug#368621: Request of maintainer, obsolete.
  • jython — Python seamlessly integrated with Java
    Bug#368791: Request of QA, orphaned, obsolete.
  • libcatalyst-model-dbic-perl — DBix::Class Model for Catalyst Framework
    Bug#369558: Request of maintainer, superseded by libcatalyst-modules-perl.
  • spidermonkey — Development files for the SpiderMonkey JS library
    Bug#369887: Request of maintainer, superseded by xulrunner.
  • xfce4-iconbox — Iconbox for the Xfce4 Desktop Environment
    Bug#370001: Request of maintainer, superseded by xfce4-panel.
  • xfce4-toys — Eyes plugin for Xfce4 panel and xfce4-tips
    Bug#370003: Request of maintainer, superseded by xfce4-session.
  • xfcalendar — Time-managing application for the Xfce desktop environment
    Bug#370004: Request of maintainer, superseded by orage.
  • xfce4-systray — Systray panel plugin for Xfce4 panel
    Bug#370000: Request of maintainer, superseded by xfce4-panel.
  • xfce4-showdesktop-plugin — Show desktop button for the Xfce4 panel
    Bug#370005: Request of maintainer, superseded by xfce4-panel.
  • xfce4-trigger-launcher — Panel plugin to start/stop programs
    Bug#370109: Request of maintainer, superseded by xfce4-panel.
  • netsaint-statd — Netsaint_statd plugins
    Bug#370334: Request of maintainer, superseded by nagios-statd packages.
  • prelude-nids — Hybrid Intrusion Detection System [ Network sensor ]
    Bug#370662: Request of maintainer, old; RC-buggy; dead upstream.
  • xffm4 — File manager for the Xfce4 desktop environment
    Bug#370749: Request of maintainer, superseded by thunar.
  • xffm4-icons — Icons for xffm4, the FM of XFce4
    Bug#373262: Request of maintainer, superseded by thunar.
  • wims-modules-fr — French modules for WIMS
    Bug#370798: Request of maintainer, replaced by wims-modules.
  • gngeogui — GUI Frontend for gngeo
    Bug#372202: Request of maintainer, front-end for already removed gngeo.
  • systemimager-ssh — SystemImager boot binaries for i386 client nodes
    Bug#372793: Request of maintainer, superseded by systemimager.
  • libsem — Portable, pthread-based semaphore library, development files
    Bug#373088: Request of maintainer, old, unused, RC-buggy.
  • pike-crypto-build — Build only package for building pike-crypto binary package
    Bug#373114: Request of maintainer, obsolete, uninstallable.
  • libattribute-handlers-perl — Simple definition of attribute handlers
    Bug#373715: Request of maintainer, obsolete.
  • libdwarf — Debugging Information Format library and documentation
    Bug#373773: Request of maintainer, obsolete; no rev-deps.
  • gnome-pim — Calendar and address book for GNOME
    Bug#373799: Request of maintainer, dead upstream; broken.
  • eli-doc — HTML and PostScript documentation for Eli
    Bug#374368: Request of maintainer, documentation for already removed eli package.
  • abc2ps — Translates ABC music description files to PostScript
    Bug#374449: Request of maintainer, dead upstream; security issues; superseded by abcm2ps.
  • sslwrap — Simple TCP service encryption using TLS/SSL
    Bug#374521: Request of maintainer, dead upstream; obsolete.
  • gal — G App Libs (development files)
    Bug#374953: Request of QA, unmaintained; obsolete; no rev-deps.
  • ipodder — Podcast receiver
    Bug#375355: Request of maintainer, license issues.
  • kernel-patch-gcov — Linux Kernel Coverage patch
    Bug#376093: Request of maintainer, superseded by linux-patch-gcov.
  • librcov-ruby — Code coverage tool for Ruby 1.8
    Bug#376453: Request of maintainer, superseded by rcov.
  • gtksourceview-sharp — CLI binding for the gtksourceview library
    Bug#376475: Request of maintainer, upstream unsupported, obsolete.
  • pgmonitor — Tcl/Tk script for examining the status of PostgreSQL backends
    Bug#376725: Request of maintainer, merged in to PostgreSQL.
  • rgtk — GNU R binding for Gtk
    Bug#376738: Request of maintainer, obsolete; dead upstream; no rev-deps.
  • callgrind — Call-graph skin for valgrind
    Bug#376950: Request of maintainer, superseded by valgrind.
  • ifenslave-2.4 — Attach and detach slave interfaces to a bonding device
    Bug#377114: Request of maintainer: outdated.
  • leo — English-German dictionary using dict.leo.org
    Bug#362016: Request of maintainer: infringes web site license.
  • linux-kernel-di-
    powerpc — Amiga filesystem support (udeb)
    Bug#362318: Request of maintainer: unused.

Chcesz dalej czytać DWN? Pomóż nam tworzyć ten tygodnik. Już kilka osób podsyła nam teksty, ale ciągle potrzebujemy nowych współautorów bądź tłumaczy. Zajrzyj na stronę pomocy, by się dowiedzieć, jak pomóc. Czekamy na Twój mail pod adresem pddp@debian.linux.org.pl.

Tłumaczenie: Bartosz Feński aka fEnIo, Lech Karol Pawłaszek, Marcin ‚iwi’ Iwiński.

Archiwalny news dodany przez użytkownika: fEnIo.
Kliknij tutaj by zobaczyć archiwalne komentarze.

Oznaczone jako → 
Share →